SMS Delays to AT&T

Incident Report for echo19

Resolved

We are no longer seeing a meaningful delay.
Posted Jan 28, 2026 - 15:11 EST

Investigating

We are seeing delays when sending 10DLC SMS messages to AT&T. The delays appear to be with the carrier. Messages are going through, but just delayed. This may cause some false-positive delivery notifications.
Posted Jan 28, 2026 - 13:38 EST
This incident affected: Peer-to-peer / Broadcast Texting Services (SMS / MMS Message Delivery).