10DLC Phone Number Activations

Incident Report for echo19

Resolved

We have been informed the incident is resolved downstream. We will continue to monitor phone numbers for appropriate activation.
Posted Jan 12, 2026 - 18:00 EST

Identified

We're seeing an issue downstream with phone numbers being delayed for 10DLC activation. Existing phone numbers are working fine, messaging isn't impacted.
Posted Jan 12, 2026 - 15:22 EST
This incident affected: Peer-to-peer / Broadcast Texting Services (10DLC Phone Number Activations).