T-mobile MMS delays

Incident Report for echo19

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 11:54 EST

Monitoring

While we're seeing some delays, the delays are getting shorter now.
Posted Oct 31, 2025 - 17:19 EDT

Investigating

We are seeing delays in delivery of T-Mobile MMS messages. It appears these messages are getting delivered, but are delayed, and we are seeing many instances of our shadowbanning alerts being triggered.
Posted Oct 31, 2025 - 16:07 EDT
This incident affected: Peer-to-peer / Broadcast Texting Services (SMS / MMS Message Delivery).