JPG MMS Delivery Issues

Incident Report for echo19

Resolved

We are seeing jpg images deliver normally to iPhones again.
Posted Apr 11, 2026 - 08:03 EDT

Identified

It appears there is an issue downstream, where JPG files are being sent in a way that appears to be working on Android phones, but is having an issues with iPhones. After testing, we have been able to get PNG files through without issues. We suggest re-encoding the file to be a PNG and use that file.

We have escalated the JPG issue downstream but we believe converting to PNG for now should address the issue.
Posted Apr 10, 2026 - 18:36 EDT

Investigating

We have heard reports from multiple customers that images are not being properly delivered to handsets. We're investigating this now. We recommend holding off on MMS programs until we can confirm what is happening.
Posted Apr 10, 2026 - 17:47 EDT
This incident affected: Peer-to-peer / Broadcast Texting Services (SMS / MMS Message Delivery).