10DLC Phone Number Activation Delays - Plum Route

Incident Report for echo19

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 12:41 EDT

Investigating

New 10LC numbers assigned to plum routes are being delayed during activation. We have escalated the issue to our downstream vendor, and we'll update the ticket once we have updates.
Posted Jun 02, 2026 - 11:55 EDT
This incident affected: Peer-to-peer / Broadcast Texting Services (10DLC Phone Number Activations).